Degraded service for watchlist screening

Minor incident Engage Individuals Engage Businesses Legl Platform UK business reports International business reports
2025-01-27 21:04 GMT · 13 hours, 27 minutes

Updates

Resolved

This incident should now be fully resolved and the backlog of failed report has been processed.

January 28, 2025 · 10:30 GMT
Monitoring

A fix has been deployed and new screening should run successfully moving forward. We’re still going through the backlog of requests for the past 12 hours.

January 28, 2025 · 10:10 GMT
Investigating

We’ve identified the root cause and a resolution is in progress. We expect the fix to be deployed in the next hour.

January 28, 2025 · 09:49 GMT
Investigating

We noticed an error causing failures to run watchlist screening for individuals and businesses. The problem started around 21:04 on the 27/01/2025.

January 28, 2025 · 09:46 GMT

← Back