Legl is currently unavailable

Major incident Engage Individuals Engage Businesses Payments Engage endpoints Business endpoints Payments endpoints Webhooks Legl Platform Legl API UK business reports International business reports
2025-02-14 17:07 GMT · 30 minutes

Updates

Resolved

Legl is up and running again—thank you for your patience!
If you experience any issues, feel free to reach out to us at support@legl.com

February 14, 2025 · 17:37 GMT
Issue

We are aware that you might not be able to access Legl. The team are currently investigating this and working to resolve the issue. If you have any further questions please contact support@legl.com

February 14, 2025 · 17:07 GMT

← Back