Incident impacting payment processing

Minor incident Payments Legl Platform
2025-04-21 20:35 BST · 9 hours, 33 minutes

Updates

Resolved

This issue has been resolved. Card payment processing has returned to normal.

April 22, 2025 · 01:30 BST
Issue

Due to an issue with our payment service provider (Adyen) experiencing downtime, users may currently be unable to make a payment via card.

This impacts Pay requests, checkouts and phone payments.

Adyen are aware and are working to resolve the issue.

April 21, 2025 · 21:03 BST

← Back