Legl dashboard appears to be down

Minor incident Engage Individuals Engage Businesses Payments Legl Platform UK business reports International business reports
2025-05-13 11:44 BST · 1 hour, 50 minutes

Updates

Resolved

This issue has been resolved and service is back up.

May 13, 2025 · 13:34 BST
Investigating

We are aware that you might be experiencing some issues with the Legl platform. The team are currently investigating this and working to resolve the issue. If you have any further questions please contact support@legl.com

May 13, 2025 · 11:44 BST

← Back