Issues with sending out documents for signature

Minor incident Engage Individuals Legl Platform
2025-08-04 13:58 BST · 2 hours, 32 minutes

Updates

Resolved

This issue has now been resolved, documents can be sent for signature.

August 4, 2025 · 16:31 BST
Issue

The third-party provider we use for sending documents for signature is experiencing issues. They are currently working on resolving the issue.

August 4, 2025 · 13:58 BST

← Back