Issue with Adyen Payouts Reporting
Minor incident
Payments
Legl Platform
2025-10-08 16:06 BST
· 1 hour, 31 minutes
Updates
Resolved
October 8, 2025 · 17:37 BST
The issue where Adyen payouts were not appearing in the transfers report on the Legl platform has been resolved. The platform is now functioning as expected, and all reporting is up to date. We apologise for any inconvenience caused and thank you for your patience.
Issue
October 8, 2025 · 16:06 BST
We are currently investigating a problem where firms are receiving Adyen payouts, but these are not appearing in the transfers report on the Legl platform. All payments are being processed correctly, and no action is required from users. We aim to resolve this reporting issue promptly.
← Back
Legl Status