Delays processing CDD reports
Minor incident
Engage Individuals
Legl Platform
2026-01-07 14:56 GMT
· 6 hours, 41 minutes
Updates
Resolved
January 7, 2026 · 21:36 GMT
This issue has been resolved. CDD report processing times should be back to normal.
Investigating
January 7, 2026 · 14:56 GMT
We are aware that there may be some delays processing CDD reports. The team are currently investigating this and working to resolve the issue. If you have any further questions please contact support@legl.com
← Back
Legl Status