Legl AI Assist

Minor incident Engage Individuals Engage Businesses Legl Platform UK business reports International business reports
2026-01-27 11:03 GMT · 6 hours, 53 minutes

Updates

Resolved

This has now been resolved.

January 27, 2026 · 17:56 GMT
Investigating

We are aware that there may be some issues across the platform with our AI assistance feature. This may affect Risk Assessments, Source of Funds and the overall Legl AI Assist feature. The team are currently investigating this and working to resolve the issue. If you have any further questions please contact support@legl.com.

January 27, 2026 · 11:03 GMT

← Back