Intermittent platform issues affecting speed and team loading
Minor incident
Engage Individuals
Engage Businesses
Payments
Engage endpoints
Business endpoints
Payments endpoints
Webhooks
Legl Platform
Legl API
UK business reports
International business reports
2026-03-26 17:46 GMT
· 1 hour, 15 minutes
Updates
Resolved
March 26, 2026 · 18:50 GMT
The intermittent issues affecting platform speed and requests loading has been resolved. All services are now operating normally.
We apologise for any disruption this may have caused and thank you for your patience.
Issue
March 26, 2026 · 17:46 GMT
We are currently investigating intermittent issues affecting platform speed and the loading of requests. Our engineers are actively working to resolve this.
We will provide further updates as our investigation progresses. We apologise for any inconvenience caused.
← Back
Legl Status