Intermittent latency affecting platform performance
Minor incident
Engage Individuals
Engage Businesses
Payments
Engage endpoints
Business endpoints
Payments endpoints
Webhooks
Legl Platform
Legl API
UK business reports
International business reports
2026-03-27 09:16 GMT
· 1 hour, 9 minutes
Updates
Resolved
March 27, 2026 · 10:26 GMT
The latency issues affecting platform performance have been resolved and all services are now operating normally. The fix has been successfully deployed.
We apologise for any disruption this may have caused and thank you for your patience.
Investigating
March 27, 2026 · 09:16 GMT
Our engineers have identified the cause of the latency issues and a fix is currently being deployed. We expect services to return to normal shortly.
We will provide a further update once the fix is live. We apologise for the continued inconvenience.
← Back
Legl Status