AI Features Partially Unavailable

Minor incident Engage Individuals Legl Platform
2026-03-30 09:32 BST · 3 hours, 4 minutes

Updates

Resolved

This incident has now been resolved and all AI-powered features are working as expected. Source of Funds summaries, CDD summaries, and Risk Assessment auto-completion and summaries have all been restored. We apologise for any inconvenience caused.

March 30, 2026 · 12:35 BST
Issue

We are aware that some AI-powered features are currently not working as expected, including Source of Funds summaries, CDD summaries, and Risk Assessment auto-completion and summaries. Our team is actively investigating and working to resolve this as quickly as possible. We apologise for any inconvenience - if you have any questions, please contact support@legl.com.

March 30, 2026 · 09:32 BST

← Back