Intermittent Platform Latency
Minor incident
Engage Individuals
Engage Businesses
Payments
Legl Platform
UK business reports
International business reports
2026-04-07 09:32 BST
· 2 hours, 28 minutes
Updates
Resolved
April 7, 2026 · 12:00 BST
We can confirm this issue has now been resolved and platform performance has returned to normal. We apologise for any inconvenience caused and thank you for your patience. If you continue to experience any issues, please contact support@legl.com.
Issue
April 7, 2026 · 09:32 BST
We are currently experiencing intermittent latency issues affecting platform performance. Our engineering team is actively investigating and working to resolve this as a priority. We apologise for any disruption to your service - for updates or queries, please contact support@legl.com.
← Back
Legl Status