Engage requests not being sent
Minor incident
Engage Individuals
Engage endpoints
Legl Platform
Legl API
2026-04-29 17:13 BST
· 29 minutes
Updates
Resolved
April 29, 2026 · 17:42 BST
Thank you for waiting while the team issued a fix for this. This has now been resolved.
Investigating
April 29, 2026 · 17:13 BST
Legl is having issues with Engage requests showing a “failed to send” error message. The team is aware of this and currently investigating. We can confirm that the requests are still being successfully sent out to clients, regardless. For any questions, please reach out directly to our Support Team at support@legl.com
← Back
Legl Status