Phone Payments
Minor incident
Payments
Legl Platform
2026-04-30 13:52 BST
· 1 hour, 24 minutes
Updates
Resolved
April 30, 2026 · 15:16 BST
The team has released a fix for the taking of phone payments and this has now been resolved. If you have any questions or experience any issues at all, please reach out directly to our Support Team at support@legl.com
Investigating
April 30, 2026 · 13:52 BST
Legl is experiencing issues with the taking of phone payments. The team is aware and actively investigating. For any questions, please reach out to our Support Team at support@legl.com
← Back
Legl Status