Intermittent errors and login issues on Legl Platform

Minor incident Engage Individuals Engage Businesses Payments Engage endpoints Business endpoints Payments endpoints Webhooks Legl Platform Legl API Pay Requests (email link to client) Payment Portal / online checkout Legl Sandbox Telephone & in-person payments Batch reminders Payment Plans / instalments Source of Funds Risk Assessments Ongoing Monitoring eSignatures CDD checks
2026-07-17 15:32 BST · 2 hours, 19 minutes

Updates

Resolved

The incident affecting the Legl Platform has now been resolved.

This was caused by an upstream outage at our infrastructure provider, Cloudflare, which disrupted certain requests; affecting logins, creating and sending requests, document uploads and payments. Cloudflare resolved the underlying issue at 17:46 BST, and these actions should now be working normally.

If you or a client were part-way through an action when the errors occurred, you can now retry - no data was lost and nothing needs to be re-set up. Where payments errored, they were not taken, so please proceed as normal.

If you continue to see any errors, please clear your browser cache or log out and back in, and contact our Support team if the issue persists.

We’re sorry for the disruption this afternoon and thank you for your patience.

July 17, 2026 · 17:49 BST
Investigating

We have identified the cause of the intermittent errors affecting the Legl Platform. This is being caused by an ongoing incident at our infrastructure provider, Cloudflare, which is currently disrupting certain requests from reaching our servers. This affects actions such as logging in, creating and sending requests, uploading documents, and taking payments.

Because the issue originates upstream with Cloudflare, some actions will succeed on retry while others intermittently fail. No data has been lost, and client-facing requests continue to be captured. Where payments have errored, they have not been taken.

We apologise for the disruption and appreciate your patience.

July 17, 2026 · 17:10 BST
Issue

We are currently investigating reports of intermittent error messages and difficulties logging in or completing certain tasks on the Legl Platform. The issue appears to be intermittent and is affecting some, but not all, users.

Client-facing requests are not impacted - your clients can continue to complete and submit requests as normal.

Our engineering team is aware and actively working on a fix. We will provide a further update shortly.

We apologise for any inconvenience and appreciate your patience.

July 17, 2026 · 15:32 BST

← Back