Issue affecting AI-assisted checks (Source of Funds, CDD & Risk Assessment)

Minor incident Engage Individuals Engage Businesses Payments Legl Platform Pay Requests (email link to client) Payment Portal / online checkout Telephone & in-person payments Batch reminders Payment Plans / instalments Source of Funds Risk Assessments Ongoing Monitoring eSignatures CDD checks
2026-07-27 12:43 BST · 6 hours, 16 minutes

Updates

Resolved

Our team has now resolved the issues affecting features that rely on AI-assisted processing, including Source of Funds, CDD summaries and Risk Assessments.

If you encounter any issues, please do reach out directly to our Support Team at support@legl.com

July 27, 2026 · 18:58 BST
Issue

We’re currently investigating an issue affecting features that rely on AI-assisted processing. The following areas may not work as expected:

  • Source of Funds - the “Continue” button may remain loading and the check may not complete.
  • CDD summaries - summaries may fail to generate.
  • Risk Assessment auto-population - fields may not populate automatically.

Other areas of the platform are unaffected. Our engineering team has identified the affected component and is working to restore service as quickly as possible.

July 27, 2026 · 12:43 BST

← Back