NFC ID verification app unavailable on Apple App Store

Minor incident Engage Individuals Legl Platform CDD checks
2026-08-14 11:21 BST · 2 hours, 32 minutes

Updates

Resolved

This issue is now resolved. The identity verification app is available again in the Apple App Store and clients using Apple devices can download it and complete their NFC check as normal.

If a client attempted a check while the app was unavailable, please ask them to reopen their original link and try again. If they are still having trouble, get in touch with our support team and we will help.

Clients using Android devices were not affected at any point, and no other areas of the Legl platform were impacted.

Thank you for your patience while our verification partner worked through this.

August 14, 2026 · 13:53 BST
Issue

We are aware of an issue affecting NFC identity checks for clients using Apple devices. The verification app is currently not appearing in the Apple App Store, which means affected clients are unable to download it and cannot complete their NFC check.

Clients using Android devices are not affected and can complete NFC checks as normal. All other areas of the Legl platform, including payments, forms and all other check types, are working normally.

This relates to the availability of the app in the App Store rather than an issue with the Legl platform itself. We have raised it with our verification partner and are waiting on an update from them. We will post again as soon as we know more.

August 14, 2026 · 11:21 BST

← Back